Chevy Trailblazer Help

Discuss non-Ford models here!

Chevy Trailblazer Help

Postby pjrocco - January 10th, 2017, 1:14 pm

I picked up a 2005 Chevy Trailblazer 4.2L 4x4 with 135,000 on it back in July of 2016. I spent $1,800 and overall it was in pretty good shape. It definitely needed some work, but since I’m mechanically inclined, I could do a lot of it myself. I’m mainly using this as a winter vehicle/camping rig. Below are the things I’ve done to it since I got it:

All new fluids
New tires
New brakes
Wheel bearing
Alternator
Spark plugs
Ignition coil in #3
Camshaft position sensor
Variable timing actuator solenoid
New rear sway bar
Blow motor resistor

I have a couple things I’m chasing, an oil leak, liftgate module issue and a couple other minor things. The main reason I’m here today is I’m looking for some insight. One issue that seemed to come up in these very cold days in Chicago is a buzzing/vibration when driving in OD between 40 – 50 MPH. If you go above 50 or lock it into 3rd, the buzzing/vibration goes away. I thought for sure if was a torque convertor. Here’s what has me puzzled. Before winter started there was no issue. Once it got cold, the issue started. In the past two days it went from 10 degrees to 40 degrees outside. Although still cold outside, I noticed with the warmer temperature the buzzing/vibration it less noticeable. Could I be dealing with something else?

Thoughts?

Thanks in advance!
pjrocco
 
Posts: 24
E-C ROOKIE
WELCOME TO E-C!
Joined: September 12th, 2016, 10:59 am
Location: Aurora, IL
My vehicle: 2011 Ford Escape XLT 3.0

Return to Non-Ford Models

Who is online

Users browsing this forum: No registered users and 2 guests